お知らせ掲示板 | 質問掲示板 | 不具合報告掲示板 | 機能要望掲示板 | 雑談掲示板

  新規投稿 ┃全記事一覧 ┃検索 ┃設定 ┃サポートフォーラムトップ  
43 / 310 ←次へ | 前へ→

Re:SP.CLBXY命令とシステム変数の不具合
 空猫  - 2013/1/9(水) 22:37 -
  
>>次にシステム変数についてですが、こちらは@_MOUSE_Lの値がCTRLキーを押している間に値が固定されてしまっています。
>>CTRLを押した状態で 0 に固定。CTRL + MOUSE_L で値が 2 に固定されています。
>>
>>ご確認よろしくお願い致します。
>
>
>どうもです。ご報告ありがとうございます。助かります。
>まず \SP.CLBXY 命令についてですが、単純な命令の定義ミスでした。
>次で修正したいと思いますが、一応ここで修正方法を説明しますと、
>
>ERIS\macro.yst 内の
>
>    macro[name=SP.CLBXY        str="\SP.CLBX($_M,$_M3,$_M4,$_M5)\SP.CLBX($_M2,$_M3,$_M4,$_M5)" ]
>
>となっている部分を
>
>    macro[name=SP.CLBXY        str="\SP.CLBX($_M,$_M3,$_M4,$_M5)\SP.CLBY($_M2,$_M3,$_M4,$_M5)" ]
>
>に置き換えていただければ動くと思います。
>
>次にシステム変数に関してですが、
>こちらではちょっと現象を確認できませんでした。
>試しに以下のスクリプトを実行してみて、値は固定になりますでしょうか。
>
>CG[ID=TX Z=1 SX=300 SY=100 FILE=""]
>LOOP[]
>{
>    CGACT[ID=TX RECTPAINT3=1 SET=0]
>    CGACT[ID=TX TEXT=1 SETSTR=$(@_MOUSE_L)]
>    WAIT[FRAME=1]
>}
>LOOPEND[]

返信ありがとうございます。
SP.CLBXY命令に関しては無事解決することが出来ました。
ありがとうございます。

しかしシステム変数に関しましてはやはり値が固定されているのではないかと思います。

少々説明不足でしたので補足しますと、YU-RISのみの状態では変数が正常に動作しているのですがERIS実行後にシナリオ中から値を確認すると発生する問題となります。

提示頂いたスクリプトでもCTRLを押すと0が表示されています。
スクリプトの実行位置ですが、#SCENARIO_START直後に追加して実行を行ったところ確認することが出来ていますがどうでしょうか?

よろしくお願い致します。

引用なし
パスワード
491 hits

SP.CLBXY命令とシステム変数の不具合 空猫 2013/1/5(土) 13:10
Re:SP.CLBXY命令とシステム変数の不具合 穂乃井 2013/1/8(火) 22:59
Re:SP.CLBXY命令とシステム変数の不具合 空猫 2013/1/9(水) 22:37
Re:SP.CLBXY命令とシステム変数の不具合 ぽてと 2014/9/16(火) 0:13
修正します 穂乃井 2014/11/8(土) 22:58

  新規投稿 ┃全記事一覧 ┃検索 ┃設定 ┃サポートフォーラムトップ  
43 / 310 ←次へ | 前へ→
19,008
(SS)C-BOARD v3.8.1β4 is Free.